Jump to content
Heritage Owners Club
Sign in to follow this  
friendofjaco

Schaller pickups?

Recommended Posts

I think you hit the nail on the head there,  FoJ.    The Schallers have more bottom end and top end,   which become mud and glare when you hit the overdrive.   When you're playing clean,  they just give it a wider overall response.    That leaves the impression of a scooped midrange to me.

Since most blues/rock players use OD,  the more midrange focused pickups are a better choice. 

 

 

Share this post


Link to post
Share on other sites

That makes sense to me as I never liked the Schaller's in any guitar that i was going to play cranked up, which is most of them. They never sounded right in my H-150 or 535 that I tended to use for playing gain-ier type of stuff. I didn't mind them in the video in a 575. I have Seth's in my H-576 and like them but when I bought it it had these kind of weird alumitones (which look kind of cool but sound kind of strange.......) in it that I didn't care for the sound of. If it had Schaller's I might have left them in.

Share this post


Link to post
Share on other sites

I find the Schallers to be very "hi-fi". They're great for pristine cleans or for a stark '80s kind of gain, but not for classic rock tones, metal chunk, or gritty blues. An odd case where the superior engineering actually worked against the product.

Share this post


Link to post
Share on other sites

I made a quick iPhone video of the schaller neck pickup tone in this guitar  just noodling on a blues. Please ignore constipation guitar face! 😂 not sure why I stopped on the iv chord. Thought it was getting too long to upload I guess.

 

https://youtu.be/eepkiTE_IbA

  • Like 2

Share this post


Link to post
Share on other sites

sounds great!! excellent tune

Share this post


Link to post
Share on other sites
30 minutes ago, bolero said:

sounds great!! excellent tune

Thanks. I'm not sure how you get it to post the video to appear right in the post!

Share this post


Link to post
Share on other sites
23 hours ago, friendofjaco said:

Thanks. I'm not sure how you get it to post the video to appear right in the post!

The trick is to use the real Youtube.com  link, not the shortcut Youtu.be link.   The board software seems the Youtube link and pastes the video.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...